Error in CGI Application: The Specified CGI Application Misbehaved by not Returning a Complete Set of HTTP Headers

You may receive the following error when publishing web forms:

Error in CGI Application
CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:
CGI open of tmpfile: Permission Denied. 

When Remark Web Survey uploads a form to the server, it first copies the files to the default temp directory (e.g., C:\Documents and Settings\Username\Temp, C:\temp or something similar).  

For this reason, the scripts need to have Read, Write, Create and Delete access to this folder. 

Note: If you are unsure what your default temp directory is, for Windows servers, go into the Control Panel, select System and then go to the Advanced tab. Click the Environment Variables tab and then look for your temp directory under System Variables.

Here are some things you can try:

  1. First you need to make sure the temp folder exists on the server. Note that your system may use a different drive, such as "D:\temp" or "F:\temp" or another variation.
  2. Then, once you are certain the temp folder exists (or alternatively once you have created it), you need to ensure that the Remark Web Survey scripts have full Read, Write, Create and Delete permissions to this folder.  To do this, add permissions to the Internet Guest Account (the account the scripts typically run under) in the temp folder.  This is the same process you used when you set up a folder for the Remark Web Survey Perl scripts on the server. 
  3. You can find out the name of the Internet Guest Account in the system's computer management area under Users (accessed via the Control Panel|Administrative Tools).  Then go to the temp folder and add this account, giving it all but full permissions. Once you have adjusted the permissions, try uploading the form again.
  4. If you are on a Linux server, ensure you modified the top line of the scripts to point to the Perl compiler.

If these steps do not resolve the problem, please double check to ensure that you uploaded the scripts to your web server in ASCII (not binary) mode.

If the problem persists after trying the above items, please contact Gravic support.

Posted - Tue, Aug 5, 2014 at 5:05 AM. This article has been viewed 22743 times.
Online URL: http://gravic.com/remark/kb//article.php?id=60

Powered by PHPKB (Knowledge Base Software)