Home » Categories » Remark Web Survey » Error Codes

Error in CGI Application: The Specified CGI Application Misbehaved by not Returning a Complete Set of HTTP Headers

You may receive the following error when publishing web forms:

Error in CGI Application
CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:
CGI open of tmpfile: Permission Denied. 

When Remark Web Survey uploads a form to the server, it first copies the files to the default temp directory (e.g., C:\Documents and Settings\Username\Temp, C:\temp or something similar).  

For this reason, the scripts need to have Read, Write, Create and Delete access to this folder. 

Note: If you are unsure what your default temp directory is, for Windows servers, go into the Control Panel, select System and then go to the Advanced tab. Click the Environment Variables tab and then look for your temp directory under System Variables.

Here are some things you can try:

  1. First you need to make sure the temp folder exists on the server. Note that your system may use a different drive, such as "D:\temp" or "F:\temp" or another variation.
  2. Then, once you are certain the temp folder exists (or alternatively once you have created it), you need to ensure that the Remark Web Survey scripts have full Read, Write, Create and Delete permissions to this folder.  To do this, add permissions to the Internet Guest Account (the account the scripts typically run under) in the temp folder.  This is the same process you used when you set up a folder for the Remark Web Survey Perl scripts on the server. 
  3. You can find out the name of the Internet Guest Account in the system's computer management area under Users (accessed via the Control Panel|Administrative Tools).  Then go to the temp folder and add this account, giving it all but full permissions. Once you have adjusted the permissions, try uploading the form again.
  4. If you are on a Linux server, ensure you modified the top line of the scripts to point to the Perl compiler.

If these steps do not resolve the problem, please double check to ensure that you uploaded the scripts to your web server in ASCII (not binary) mode.

If the problem persists after trying the above items, please contact Gravic support.

5 (2)
Article Rating (2 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Image Appears as Broken Link in Remark Web Survey
Viewed 2114 times since Tue, Aug 5, 2014
Internal Server Error when Accessing the Administration and/or Data Collection Scripts
Viewed 2163 times since Tue, Aug 5, 2014
Error #1935 Installing Software
Viewed 5254 times since Fri, Aug 29, 2014
File in Use Error when Connecting to an Access/Excel 2010 File
Viewed 2309 times since Tue, Aug 5, 2014
Error #481, Invalid Picture when Inserting an Image into a Remark Web Survey Form
Viewed 2917 times since Tue, Aug 5, 2014
404 File Not Found Error when Accessing the Admin Control Panel from the Designer Component
Viewed 3969 times since Tue, Aug 5, 2014
Error #9000
Viewed 4555 times since Tue, Aug 5, 2014
Forbidden Error Message when Accessing the Administration and/or Data Collection Script
Viewed 2423 times since Tue, Aug 5, 2014
File Access Error: /webform-1.resx when Accessing a Form
Viewed 2094 times since Tue, Aug 5, 2014
Field Too Small Error when Saving Data
Viewed 3002 times since Tue, Aug 5, 2014